Q: How to compile this code?

You can not compile this code, because it depends on tdlib project and it's code is not yet published.

Q: Can not run telegram-cli. It fails with error CXXABI_1.3.8 not found

Probably you just need to update gcc to newer version (4.9 will do)